Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE

看到这个问题,说明你是个勇士(其实就是敢死队)
能找到本文,你就是勇士中的勇士

Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE

这个问题出现原因,AS 的beta/alpha版本,有40天的限制,40天后,会强制让你更新到正式版(或最新版)。

谷歌大大最近在搞3.0 ,没空整2.4 ,啃爹的3.0 又各种内存泄露。

解决办法:

  1. 设置环境变量 ANDROID_DAILY_OVERRIDE = xxxx
    mac 环境变量方法 launchctl setenv ANDROID_DAILY_OVERRIDE xxxx
    windows / linux 自己看着设置吧
  2. 使用最新版本

网上还有让把gradle插件设置到最新版本的,别折腾了,不好使。